Kompozer el Dreamweaver de GNU/Linux

Standard

Aca les dejo un mini tutorial, para instalar Kompozer, visto que vi en muchos foros gente que queria emular el Dreamweaver, esta es una alternativa Libre, no tan completisima como el Dreamweaver pero esta muy bien para empezar, este tuto lo hize cuando estaba libre de tiempo…


KompoZer es un editor HTML WYSIWYG basado en Nvu similar a Dreamweaver con la diferencia de que es un proyecto Open Source de licencia GNU/GPL 2.0

Pasos

1. Descargando Kompozer

Descargar el paquete necesario de la web http://kompozer.net

Tienen varias opciones, bajar el .dev el .rpm y el tar,gz para compilar, bajaremos este ultimo, si usas Ubuntu con el .deb basta…

Fichero Descargado: kompozer-0.7.10-gcc4.0.3-i486.tar.gz

2. Descomprimiendo el fichero

Ubicado el fichero /home/zarpele (podemos ponerlo donde sea, pero aca esta bien para mantener un orden) descomprimir el fichero descargado…

Desde Consola:

guido@zarpele ~ $ tar -xvzf kompozer-0.7.10-gcc4.0.3-i486.tar.gz

3. Ejecutando Kompozer

cd /kompozer
sudo ./kompozer

y si todo salio bien obtener acto seguido la interfaz gráfica de Kompozer.

4. Cambiando el Idioma

Como podran ver el idioma por default es en ingles asi que desde este link http://kompozer.net/l10n/ y bajaremos el archivo en Español (es-ES)

Fichero Descargado: kpz-langpack-esES.xpi

Lo movemos aca /home/zarpele/kompozer/extensions (en nuestro ejemplo)

Ahora para cada extension que queramos instalar debemos hacerlo desde el menu Tools (herramientas) -> Extensions (extensiones) -> Install (instalar) y seleccionar la extensión (kpz-langpack-esES.xpi es la extensión que me cambia al idioma español todo el programa) y clicar Install now (instalar ahora). Para que los cambios tengan efecto tenes que cerrar y volver a abrir el kompozer.

Y listo, ya solo es cuestion de usarlo un poco…
Les dejo 2 capturas

Saludos…

FB Comentarios

2 thoughts on “Kompozer el Dreamweaver de GNU/Linux

  1. hola!
    no se si sigues por ahí, pero por si acaso! :-)

    llevo cacharreando un buen rato y mi cabeza empieza a echar humo… jeje

    Instalé kopozer 1:0.8
    pero no vi que versión era antes de… instalar el paquete para el idioma correspondiente a 07.10 … y ahora al querer iniciar kompozer me aparece una pantalla de error (evidente, que metedura de pata) de la cual no pasas, intenté averiguar donde podía deshacer el cambio pero no lo consigo, si desistalo el paquete kompozer y lo instalo de nuevo sique apareciendo!
    no sé, conoces alguna forma de deshacer el entuerto=? es posible, desde consola desistalar el paquete de idioma o arreglarlo de alguna forma ya que no puedo ejecutar ni instalar de nuevo el kompozer: Me indica esto al ejecutarlo:

    Error de lectura XML: entidad no definida
    Ubicación: chrome://editor/content/editor.xul
    Número de línea 230, columna 7:
    ——^ <key id="key_openHelp"
    —-^ <menuitem label="&addons.label;"
    ——^ <menuitem id="spell-no-suggestions"
    ——^

  2. mira hace años que no uso este programa pero intenta desintalarlo completamente y en la carpeta de tu usuario elimina una carpeta .kompozer (Crtl+H para ver carpetas ocultas) y kompozer y proba hacer lo mismo… Ahi se guardan todos los archivos de configuración del programa por si en futuro quieres volver a usarlo…

    Cualquier cosa avisas…
    Saludos..

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>